First Install OpenWRT

Download openwrt-17.01.5-ar71xx-generic-tl-wr720n-v3-squashfs-factory.binOpenWrt 下载 适合WR720N的安装包

and upload to admin dashboard - upgrade page. 打开WR720N 的系统管理界面 , 上传安装包

That’ll auto reboot when complete. 等待上传完成 , 系统自动完成升级过程

Replace Flash to 16M

将 Flash Chip 装入编程器,使用编程工具将固件写入芯片。

使用热风枪加热外壳并使用美工刀沿缝隙切开,取下主板

找到 Flash Chip 的位置,在锡纸中间挖洞,漏出芯片

热风枪开到300摄氏度左右,使用芯片拔出器或者镊子取下

用洗板水清理主板焊盘,换上 16M Flash Chip 热风枪回流

清理主板,在外壳边缘涂上少量胶水装好外壳。

First Login

完成后将本机与WR720N 的 WAN/LAN 用网线连接 , 网络设置为 192.168.1.1 ,然后使用 Telnet 登录 telnet 192.168.1.1

BusyBox v1.17.3 (2011-02-22 23:42:42 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r26290) ----------
  * 1/4 oz Vodka      Pour all ingredents into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@openwrt:~$

在命令行中输入 passwdroot 用户设置密码:

root@openwrt:~$ passwd
Changing password for root
New password:
Retype password:
Password for root changed by root
root@openwrt:~$

完成后 , 会自动启用 SSH 服务 , 使用 ssh root@192.168.1.1 登陆

重新启动

reboot && exit

cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/PLATFORM/xxx-sysupgrade.bin
sysupgrade -v /tmp/openwrt-ar71xx-generic-wzr-hp-ag300h-squashfs-sysupgrade.bin  

安装软件

使用 ssh root@192.168.1.1 登陆

更新软件源

opkg update

安装 Web 管理界面

opkg install luci

重新启动

reboot && exit

配置

修改网络参数

vi /etc/config/network

config interface 'lan'
option ifname 'eth1'
option type 'bridge'
option proto 'static'
option ipaddr '10.1.2.1'            #WR720N的地址
option netmask '255.255.255.0'
option ip6assign '60'

vi /etc/config/wireless

config wifi-device  radio0
    option type     mac80211
    option channel  11
    option hwmode   11ng
    option path 'platform/ar933x_wmac'
    option htmode   HT20
    list ht_capab   SHORT-GI-20
    list ht_capab   SHORT-GI-40
    list ht_capab   RX-STBC1
    list ht_capab   DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    # option disabled 1             #将该行注释 , 启用WIFI

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'mini@lsong.org'    #SSID 名称
    option encryption 'psk-mixed'   #加密方法
    option key 'song940@163.com'    #密码

Boot from usb

opkg update
opkg install kmod-usb-core kmod-usb-uhci kmod-usb-storage  kmod-usb2  kmod-fs-ext3

-

mount /dev/sda1 /mnt

-

tar -C /overlay -cvf - . | tar -C /mnt -xf -

/etc/config/fstab

config 'global'
    option  anon_swap       '0'
    option  anon_mount      '0'
    option  auto_swap       '1'
    option  auto_mount      '1'
    option  delay_root      '5'
    option  check_fs        '0'

config 'mount'
    option  target  '/mnt'
    option  uuid    'ced46a51-951a-4d22-be2a-b7cebbd66d44'
    option  enabled '1'
    option fstype   ext4
    option options  rw,sync
    option enabled_fsck 1
    option is_rootfs 1  

All done .